EM mess – by Slyt – OTN Forum

I tried to run EM on certain host:

[oracle@SQLAB db10g]$ emctl dbconsole start

 TZ set to
Poland
EM Configuration issue. /u01/app/oracle/product/10.2.0/db10g/SQLAB_e2k not found.

OK. No such dir indeed. So:

[oracle@SQLAB db10g]$ emca -config dbcontrol db -repos createblablabla
Do you wish to continue? [yes(Y)/no(N)]: Y
2008-06-19 13:12:12 oracle.sysman.emcp.EMConfig perform
INFO: This operation is being logged at

/u01/app/oracle/product/10.2.0/db10g/cfgtoollogs/emca/e2k/emca_2008-06-19_01-11-47-PM.log.
2008-06-19 13:12:13 oracle.sysman.emcp.EMReposConfig createRepository
INFO: Creating the EM repository (this may take a while) …
2008-06-19 13:12:13 oracle.sysman.emcp.EMReposConfig invoke
SEVERE: Error creating the repository
2008-06-19 13:12:13 oracle.sysman.emcp.EMReposConfig invoke
INFO: Refer to the log file

at /u01/app/oracle/product/10.2.0/db10g/cfgtoollogs/emca/e2k/emca_repos_create_<date>.log for more details.
2008-06-19 13:12:13 oracle.sysman.emcp.EMConfig perform
SEVERE: Error creating the repository
Refer to the log file at /u01/app/oracle/product/10.2.0/db10g/cfgtoollogs/emca/e2k/emca_2008-06-19_01-11-47-PM.log for more details.
Could not complete the configuration. Refer to the log file at /u01/app/oracle/product/10.2.0/db10g/cfgtoollogs/emca/e2k/emca_2008-06-19_01-11-47-PM.log for more details.

 What log says:

emca_2008-06-19_01-11-47-PM.logCheck if repos user already exists.stare 6: WHERE username=UPPER(’&EM_REPOS_USER’);
nowe 6: WHERE username=UPPER(’SYSMAN’);
stare 8: IF ( ‘&EM_CHECK_TYPE’ = ‘EXISTS’) THEN
nowe 8: IF ( ‘NOT_EXISTS’ = ‘EXISTS’) THEN
stare 11: raise_application_error(-20000, ‘&EM_REPOS_USER does not exists..’);
nowe 11: raise_application_error(-20000, ‘SYSMAN does not exists..’);
stare 14: ELSIF ( ‘&EM_CHECK_TYPE’ = ‘NOT_EXISTS’ ) THEN
nowe 14: ELSIF ( ‘NOT_EXISTS’ = ‘NOT_EXISTS’ ) THEN
stare 17: raise_application_error(-20001, ‘&EM_REPOS_USER already exists..’);
nowe 17: raise_application_error(-20001, ‘SYSMAN already exists..’);
stare 21: raise_application_error(-20002, ‘Invalid Check type &EM_CHECK_TYPE’);
nowe 21: raise_application_error(-20002, ‘Invalid Check type NOT_EXISTS’);
DECLARE
*
ERROR at line 1:
ORA-20001: SYSMAN already exists..
ORA-06512: at line 17
What next ? Should I drop user SYSMAN and try again ?

>>>>Francisco Munoz Alvarez Answer

 Hi SlyT, Yes you need to drop the repository first.


emca -deconfig dbcontrol db -repos drop
emca -repos create
emca -config dbcontrol db

Best Regards,

Francisco Munoz Alvarez
www.oraclenz.com

>>> SlyT Replay

Hi Francisco,
not so easy …

 
[oracle@SQLAB e2k]$ emca -deconfig dbcontrol db -repos dropblablabla
Do you wish to continue? [yes(Y)/no(N)]: Y
2008-06-19 13:42:57 oracle.sysman.emcp.EMConfig perform
INFO: This operation is being logged

at /u01/app/oracle/product/10.2.0/db10g/cfgtoollogs/emca/e2k/emca_2008-06-19_01-42-42-PM.log.
2008-06-19 13:42:57 oracle.sysman.emcp.EMDBPreConfig performDeconfiguration
WARNING: EM is not configured for this database. No EM-specific actions can be performed.
2008-06-19 13:42:57 oracle.sysman.emcp.EMReposConfig dropRepository
INFO: Dropping the EM repository (this may take a while) …
2008-06-19 13:42:58 oracle.sysman.emcp.util.PlatformInterface executeCommand
WARNING: Error executing /u01/app/oracle/product/10.2.0/db10g/sysman/admin/emdrep/bin/RepManager -connect (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=SQLAB)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=e2k))) -repos_user SYSMAN -action drop -verbose -output_file /u01/app/oracle/product/10.2.0/db10g/cfgtoollogs/emca/e2k/emca_repos_drop_2008-06-19_01-42-57-PM.log
2008-06-19 13:42:58 oracle.sysman.emcp.EMReposConfig invoke
SEVERE: Error dropping the repository
2008-06-19 13:42:58 oracle.sysman.emcp.EMReposConfig invoke
INFO: Refer to the log file at /u01/app/oracle/product/10.2.0/db10g/cfgtoollogs/emca/e2k/emca_repos_drop_<date>.log for more details.
2008-06-19 13:42:58 oracle.sysman.emcp.EMConfig perform
SEVERE: Error dropping the repository
Refer to the log file

at /u01/app/oracle/product/10.2.0/db10g/cfgtoollogs/emca/e2k/emca_2008-06-19_01-42-42-PM.log for more details.
Could not complete the configuration. Refer to the log file at /u01/app/oracle/product/10.2.0/db10g/cfgtoollogs/emca/e2k/emca_2008-06-19_01-42-42-PM.log for more details.


 >>> Francisco Munoz Alvarez Answer

Can you post the log information?

Cheers,

Francisco Munoz Alvarez
www.oraclenz.com
 

>>> Slyt Replay

It’s a little bit log, I would attached it but I can not see the way. So (some messages translated from my native language):

2008-06-19 13:42:57 oracle.sysman.emcp.util.PlatformInterface executeCommand
CONFIG: Starting execution: /u01/app/oracle/product/10.2.0/db10g/sysman/admin/emdrep/bin/RepManager -connect (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=SQLAB)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=e2k))) -repos_user SYSMAN -action drop -verbose -output_file /u01/app/oracle/product/10.2.0/db10g/cfgtoollogs/emca/e2k/emca_repos_drop_2008-06-19_01-42-57-PM.log
2008-06-19 13:42:58 oracle.sysman.emcp.util.PlatformInterface executeCommand
CONFIG: Exit value of 50
2008-06-19 13:42:58 oracle.sysman.emcp.util.PlatformInterface executeCommand
CONFIG: Enter SYS user’s password :
Enter repository user password :
Getting temporary tablespace from database…
Could not connect to SYS/(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=SQLAB)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=e2k))): ORA-01017: incorrect user/password; login failed (DBD ERROR: OCISessionBegin)
2008-06-19 13:42:58 oracle.sysman.emcp.util.PlatformInterface executeCommand
CONFIG: stty: standard input: Invalid argument
stty: standard input: Invalid argument
stty: standard input: Invalid argument
stty: standard input: Invalid argument

>>> Francisco Munoz Alvarez Answer

Dear Slyt,

You enter the wrong SYS password:

CONFIG: Enter SYS user’s password :
Enter repository user password :
Getting temporary tablespace from database…
Could not connect to SYS/(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=SQLAB)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=e2k))): ORA-01017:
incorrect user/password; login failed (DBD ERROR: OCISessionBegin)
 
Look for the right password and try again.

Best Regards,

Francisco Munoz Alvarez
www.oraclenz.com

>>> SlyT Replay

Dear Francisco ;D,
Thank you very much for your fast and reliable support.
Everything is OK now.

Best regards,
Slawomir Trojniak

Advertisements

Oracle ACE Director and President of LAOUC, NZOUG and CLOUG. Organizer of LA and APAC OTN Tours,

Posted in Questions

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: